[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] Problems launching games using Cedega



On Sun, 12 Nov 2006 07:37:39 -0800 Andrew Grimberg <tykeal@bardicgrove.org>
babbled:

> Greets folks,
> 
> Ok, I know, the subject makes this look like a Cedega problem.  However,
> I only ever have problems if I'm using E17 as my WM and I've tried it
> under Gnome, KDE and Failsafe modes, ergo I'm really having to believe
> it's E.  As I'm not getting any stack traces or anything from this let
> me describe what I'm seeing.
> 
> First, here's the system configuration:
> 
> OS: Fedora Core 6
> Graphics: nVidia Corporation GeForce 7900 GT (dual head card)
> Graphics Driver: nVidia binary driver rev: 1.0.9629 built as a DKMS
> module packaged by FreshRPMS / RPMForge.
> E17: enlightenment-0.16.999.036-1.20061107cvs from Didier's RPM repo
> (yesterday)
> Cedega: 5.2.3 / 5.2.7 (interface / engine)
> 
> At present moment I only have the following games installed under
> Cedega: Half-Life2 and World of Warcraft (run using opengl)
> 
> What I'm seeing is this:
> 
> With Half-Life2, steam starts its connection to verify my account, does
> so and then launches HL2. The screen goes black and just hangs.
> 
> With World of Warcraft, the game attempts to start but I get back the
> following message: Your 3D accelerator card is not supported by Word of
> Warcraft.  Please install a 3D accelerator card with dual-TMU support.
> 
> Everything I've found out about dual-TMU error seems to point to not
> enough, too many or not the correct OpenGL options are getting passed
> into the game.
> 
> A little bit more info as I was running through other scenarios writing
> this message.
> 
> If I remove the opengl flag from WoW (making it run D3D through OGL),
> the game does launch... however, it tries to open on screen :0.1 instead
> of :0.0 and never displays anything (as it does it's resolution change
> to one screen, but it gets thrown to the second monitor which has been
> effectively removed by the resolution change).  If I switch my
> resolution down to one screen only before launching the game then it
> launches fine (in D3D mode) but gives me the same error with OGL.
> 
> For HL2, if I switch to one screen, it loads up, gives me a clean
> display for a moment then everything goes all garbage on screen.
> 
> I'm going to submit a bug over to Transgaming on this as well, but I
> figured as I only ever have these problems under E17 and as E happens to
> be my preferred WM I would send this out and see if anyone else has seen
> this, knew about it or if it's even helpful information.  I really don't
> want to be switching DE's just to play the games that I've got.

at this stage its best that transgaming and us (e devs) work together. as best
i cam imagine its likely something in wine - as it will ASSUME behavior on the
part of a wm and windows apps will ASSUME certain things. those assumptions may
not be valid under e - what they are, i don't know - but i can bet you
transgaming do NOT test wine under e17 thus they have no idea of what specific
scenarios may happen there. invariably the problems like this end up being
broad assumptions on the part of java/wine/etc. that are incorrect for e and
they already have special workarounds for other wm's where they detect the
situation is different, but have no such workaround for e17.

until we have much mroe detailed info - i can't say much. if e17 was
segfaultign or e17 process was locking up solid - i'd definitely fix that as
thats an e bug. now with complex interactions of a wm and the windows it
manages - who knows. it could be anything. chances are though it is more likely
to be a wine issue or a "windows apps" issue assuming windows as their display
environment.

-- 
------------- Codito, ergo sum - "I code, therefore I am" --------------
The Rasterman (Carsten Haitzler)    raster@rasterman.com
裸好多
Tokyo, Japan (東京 日本)