[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] 'Restart' menu item exits Enlightenment ( 0.17 )



Thomas Kuther wrote:
> On Wed, 15 Nov 2006 14:28:54 +1100
> Metrics <metrics@score5.org> wrote:
> 
>> On Wed, Nov 15, 2006 at 01:41:57PM +1100, Daniel Kasak wrote:
>>> For around a week or more now, the 'Restart' menu item has been
>>> shutting down Enlightenment-0.17 for me instead of restarting it.
>>>
>>> -- 
>>> Daniel Kasak
>>> IT Developer
>>> NUS Consulting Group
>>> Level 5, 77 Pacific Highway
>>> North Sydney, NSW, Australia 2060
>>> T: (+61) 2 9922-7676 / F: (+61) 2 9922 7989
>>> email: dkasak@nusconsulting.com.au
>>> website: http://www.nusconsulting.com.au
>>>
>> The cause is most probably due to the fact that the enlightenment
>> binary in your install is not called "enlightenment". On gentoo it's
>> something like "enlightenment-0.17" or something. Symlink will fix
>> it. 
>>
>> metrics
>>
> 
> seconded!
> works on my vector laptop where the binary is called "enlightenment",
> and fails on the gentoo box, where the ebuild installs it as
> "enlightenment-0.17". 
> The e ebuild needs a fix, as e16 installs as "e16" anyway. Just older
> versions of e16 would be affected.
> Currently the ebuild does an ugly hack and seds enlightenment -->
> enlightenment-0.17 in e_start_main.c
> 
> Regards,
> Tom
> 
> 

On Gentoo it configures enlightenment with the binary-executable-name
thingy a little different, the right option should be - imo - that the
restart option uses that configuration-setting, propably from config.h