[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[E-devel] Problems launching games using Cedega



Greets folks,

Ok, I know, the subject makes this look like a Cedega problem.  However,
I only ever have problems if I'm using E17 as my WM and I've tried it
under Gnome, KDE and Failsafe modes, ergo I'm really having to believe
it's E.  As I'm not getting any stack traces or anything from this let
me describe what I'm seeing.

First, here's the system configuration:

OS: Fedora Core 6
Graphics: nVidia Corporation GeForce 7900 GT (dual head card)
Graphics Driver: nVidia binary driver rev: 1.0.9629 built as a DKMS
module packaged by FreshRPMS / RPMForge.
E17: enlightenment-0.16.999.036-1.20061107cvs from Didier's RPM repo
(yesterday)
Cedega: 5.2.3 / 5.2.7 (interface / engine)

At present moment I only have the following games installed under
Cedega: Half-Life2 and World of Warcraft (run using opengl)

What I'm seeing is this:

With Half-Life2, steam starts its connection to verify my account, does
so and then launches HL2. The screen goes black and just hangs.

With World of Warcraft, the game attempts to start but I get back the
following message: Your 3D accelerator card is not supported by Word of
Warcraft.  Please install a 3D accelerator card with dual-TMU support.

Everything I've found out about dual-TMU error seems to point to not
enough, too many or not the correct OpenGL options are getting passed
into the game.

A little bit more info as I was running through other scenarios writing
this message.

If I remove the opengl flag from WoW (making it run D3D through OGL),
the game does launch... however, it tries to open on screen :0.1 instead
of :0.0 and never displays anything (as it does it's resolution change
to one screen, but it gets thrown to the second monitor which has been
effectively removed by the resolution change).  If I switch my
resolution down to one screen only before launching the game then it
launches fine (in D3D mode) but gives me the same error with OGL.

For HL2, if I switch to one screen, it loads up, gives me a clean
display for a moment then everything goes all garbage on screen.

I'm going to submit a bug over to Transgaming on this as well, but I
figured as I only ever have these problems under E17 and as E happens to
be my preferred WM I would send this out and see if anyone else has seen
this, knew about it or if it's even helpful information.  I really don't
want to be switching DE's just to play the games that I've got.

-Andy-

Attachment: smime.p7s
Description: S/MIME cryptographic signature