[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] automake 1.10 again



On Tue, 31 Oct 2006 15:46:39 -0500 Mike Frysinger <vapier@gentoo.org> babbled:

> On Tuesday 31 October 2006 06:13, Carsten Haitzler wrote:
> > as best i see right now - i don't know of our "problem" - i only hear about
> > ugly workarounds and hacks to "make it work" with a tool developers are not
> > actually using (thus it's irrelevant).
> 
> we illustrated it pretty clearly in one of the previous threads ;)
> 
> the problem:
> e17 code misuses gettext autotool features ... in this case, we call 
> AM_GNU_GETTEXT() in configure.in but then fail to provide any of the gettext 
> helper files (in this case config.rpath)
> 
> older automake versions (<=1.9) would not catch this and so at runtime you 
> would see things like configure complaining about ./config.rpath not being 
> found, but the build would go on.  with automake-1.10+, these files are 
> explicitly checked for and so automake aborts saying that config.rpath was 
> not provided when it is needed
> 
> the fix may be to run autopoint or gettextize ... i havent put forth anything 
> as i havent studied the e17 handling of po subdirs and the little i have 
> looked shows that they are definitely non-standard ...
> -mike

well e17 has an autopoint -f already. here it doesn't create a config.rpath.
putting config.rpath in cvs itself is just a stupid idea - if it can be
generated (and is a generated file). i'll throw in a gettextize -f - but
unfortunately it is not a non-interactive tool. it requires human
acknowledgement. i've hacked around it but it's an ugly hack and might break
on slow/overloaded systems. (it actually reads /dev/tty so pipes dont work)



-- 
------------- Codito, ergo sum - "I code, therefore I am" --------------
The Rasterman (Carsten Haitzler)    raster@rasterman.com
裸好多
Tokyo, Japan (東京 日本)