[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] Larger diff against CVS concernig autofoo and debian/*




On Oct 24, 2006, at 3:54 PM, Carsten Haitzler (The Rasterman) wrote:

On Tue, 24 Oct 2006 12:09:11 -0700 Blake Barnett <shadoi@nanovoid.com> babbled:


On Oct 24, 2006, at 11:48 AM, Michael Jennings wrote:

On Tuesday, 24 October 2006, at 10:48:16 (-0700),
Blake Barnett wrote:

And even still, it shouldn't matter.  If people are going to change
their source for the packages (especially going to the main
repository), they need to remove all the packages from conflicting
repositories.

Then why did you put the epoch in there to begin with? Might it have
been to easily override/replace the packages from other repositories
without as much manual intervention?  Hmmmm....  :-)

We did it because it was a support nightmare to explain why the main
repository packages always took precedence, even though their version
was lower.  It "works as expected" for users this way.

eh? if you were both on the same epoch - your version should take precedence -
why are you at 2 if debian is at 1?

Yup. Bad choice. We can remedy it, just set the epoch back to 1 and make the next packages in the repository conflict with any versions greater than "2:" (if that's possible, should be). It'll annoy people, I'm sure. I didn't realize at the time I recommended it that it was incorrect. My bad. If Lut1n and Kaethorn don't read it here, I'll let them know.

-Blake