[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] Larger diff against CVS concernig autofoo and debian/*



On Tue, 24 Oct 2006 14:48:19 -0400 Michael Jennings <e-devel@kainx.org> babbled:

> On Tuesday, 24 October 2006, at 10:48:16 (-0700),
> Blake Barnett wrote:
> 
> > If it does, it's not documented in the policy manual.
> 
> Seems to me that the only valid purpose for an Epoch would be to act
> as a "superversion" in case of dramatic versioning convention changes
> (such as YYYYMMDD -> X.Y.Z) and such.  And that only works if it
> supercedes version.
> 
> > And even still, it shouldn't matter.  If people are going to change
> > their source for the packages (especially going to the main
> > repository), they need to remove all the packages from conflicting
> > repositories.
> 
> Then why did you put the epoch in there to begin with?  Might it have
> been to easily override/replace the packages from other repositories
> without as much manual intervention?  Hmmmm....  :-)
> 
> Now people start to see why cAos policy forbids epochs.  Epoch is like
> suicide:  it's a permanent solution to a temporary problem.

i would disagree with banning it - but HEAVILY discouraging it i do agree with.
the reason for my moans was just seeing the "oh - we can get out packages
preferred over their packages as long as we just keep our epoch higher!" and
before you know it you have multiple repositories competing by just raising
epochs. epoch war! oh fun. it should never even have been used to start with -
there was never any reason to bring it in to start with as we have not done any
major shifts in versioning in any official release - ever.

> Michael
> 
> -- 
> Michael Jennings (a.k.a. KainX)  http://www.kainx.org/  <mej@kainx.org>
> n + 1, Inc., http://www.nplus1.net/       Author, Eterm (www.eterm.org)
> -----------------------------------------------------------------------
>  "I disapprove of what you say, but I will defend to the death your
>   right to say it."                                        -- Voltaire
> 
> -------------------------------------------------------------------------
> Using Tomcat but need to do more? Need to support web services, security?
> Get stuff done quickly with pre-integrated technology to make your job easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________
> enlightenment-devel mailing list
> enlightenment-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/enlightenment-devel
> 


-- 
------------- Codito, ergo sum - "I code, therefore I am" --------------
The Rasterman (Carsten Haitzler)    raster@rasterman.com
裸好多
Tokyo, Japan (東京 日本)