[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] building with automake-1.10



On Tuesday, 17 October 2006, at 17:51:42 (-0400),
Mike Frysinger wrote:

> actually we're both wrong
> 
> the error is this:
> configure.in:152: required file `./config.rpath' not found
> 
> the warnings are these:
> configure.in:8: installing `./missing'
> configure.in:8: installing `./install-sh'
> po/Makefile.am:6: addsuffix .mo,$(ALL_LINGUAS: non-POSIX variable name
> po/Makefile.am:6: (probably a GNU make extension)
> po/Makefile.am:8: addsuffix .po,$(ALL_LINGUAS: non-POSIX variable name
> po/Makefile.am:8: (probably a GNU make extension)
> po/Makefile.am:10: `%'-style pattern rules are a GNU make extension
> src/bin/Makefile.am: installing `./depcomp'

Oh, okay.  If they're non-fatal, that's cool.  I guess I shouldn't
jump to conclusions, eh? :)

config.rpath is relatively new; what version of automake brought that
about?

Unfortunately, autoreconf is also fairly new, and it doesn't always
work.  Perhaps what we need is an attempt to autoreconf where failure
falls back to the old way of doing things one by one and allowing for
the possibility of failure for certain auto* commands that might not
exist (like the one that creates config.rpath).

Opinions?

Michael

-- 
Michael Jennings (a.k.a. KainX)  http://www.kainx.org/  <mej@kainx.org>
n + 1, Inc., http://www.nplus1.net/       Author, Eterm (www.eterm.org)
-----------------------------------------------------------------------
 "I have tasted my own hunger, sold my body to survive.  Some have
  paid to scratch the surface, but they can't touch what's inside."
                              -- Richard Marx, "Children of the Night"