[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] building with automake-1.10



On Tue, 17 Oct 2006 17:51:42 -0400 Mike Frysinger <vapier@gentoo.org> babbled:

> On Tuesday 17 October 2006 17:20, Michael Jennings wrote:
> > Mike Frysinger wrote:
> > > in this case, the error is informative ... the makefiles are
> > > [incorrectly] trying to use GNU makism's in otherwise portable code
> >
> > That's not the problem.  The problem is that automake 1.10 is
> > [incorrectly] (sic) counting as an error what is more properly a
> > warning and for what previously didn't even generate *that*.
> 
> actually we're both wrong
> 
> the error is this:
> configure.in:152: required file `./config.rpath' not found

which to me smells of an autofoo problem as this would be something
auto-generated by autoconf (or a combination of automake macros for autoconf
etc.) etc. definitely not something we need to supply.

> the warnings are these:
> configure.in:8: installing `./missing'
> configure.in:8: installing `./install-sh'
> po/Makefile.am:6: addsuffix .mo,$(ALL_LINGUAS: non-POSIX variable name
> po/Makefile.am:6: (probably a GNU make extension)
> po/Makefile.am:8: addsuffix .po,$(ALL_LINGUAS: non-POSIX variable name
> po/Makefile.am:8: (probably a GNU make extension)
> po/Makefile.am:10: `%'-style pattern rules are a GNU make extension
> src/bin/Makefile.am: installing `./depcomp'
> -mike
> 


-- 
------------- Codito, ergo sum - "I code, therefore I am" --------------
The Rasterman (Carsten Haitzler)    raster@rasterman.com
裸好多
Tokyo, Japan (東京 日本)