[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] Eterm cut and paste doesn't work on x86_64 with gcc4.1.1



On Tuesday, 03 October 2006, at 08:42:34 (-0400),
Dan Gregory wrote:

> Several gentoo (and a suse) users have been having trouble with Eterm
> specifically with it's interface with xselection.  We think that we have
> narrowed it down to x86_64 with gcc4.  The behavior is that you can
> cut/paste within a select group of type of windows (eterms, xterms, firefox,
> thunderbird), but you can't paste into other types (opera, ooffice, knotes,
> etc.)  The only clue that I have is that I ran klipper (kde's
> clipboard/xselection tool) in a terminal and tried to select from an eterm.
> When I do, I get the following error as soon as I mouseup following the
> selection:
> 
> X Error: BadAtom (invalid Atom parameter) 5
>   Major opcode:  17
>   Minor opcode:  0
>   Resource id:  0x3200048
> 
> I have tried to hack scr/screen.c, but I haven't been successful in
> pinpointing the issue.
> 
> Can anyone here give me a push in the right direction?

If it ONLY happens on x86_64 and it ONLY happens with gcc 4, don't you
think that sounds like a gcc bug?  I sure do.

Tried gcc3?

Michael

-- 
Michael Jennings (a.k.a. KainX)  http://www.kainx.org/  <mej@kainx.org>
n + 1, Inc., http://www.nplus1.net/       Author, Eterm (www.eterm.org)
-----------------------------------------------------------------------
 "My program's in an infinite loop.  Should I wait for it to
  finish?"   -- some lame luser in a Tarleton State Univ. computer lab