[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] Evas (evas_fb_test) crashing on 8bps framebuffers



On Tuesday 05 September 2006 12:55, Carsten Haitzler babbled:
> On Tue, 5 Sep 2006 11:32:28 +0200 Rene Rebe <rene@exactcode.de> babbled:
> > Hi,
> >
> > most framebuffer drivers (nvidia, radeon, ...) default to 8bps and all
> > non-x86 machines such as PPC ones run this per default. However Evas
> > (evas_fb_test) crashes on 8bps because no convert function is matched and
> > crashes in
> >
> > evas_fb_outbuf_fb_get_height (buf=0x0) at evas_outbuf.c:365
> >
> > because the buffer is nil - which is returned by:
> >
> > evas_fb_outbuf_fb_setup_fb(w, h, rot, OUTBUF_DEPTH_INHERIT, vt, dev,
> > refresh);
> >
> > which in turn calls:
> >
> > evas_common_convert_func_get (dest=0x0, w=1024, h=768, depth=8,
> > rmask=255, gmask=255, bmask=255,
> >     pal_mode=PAL_MODE_NONE, rotation=0) at evas_convert_main.c:15
> >
> > Maybe someone with more evas internals in mind can help fixing this
> > up properly?
>
> there is no 8bpp support for fb in evas. that is why. there is no converter
> for 8bpp when in the fb  (because there is no palette allocation code).

Any chance this can be fixed, e.g. FBIOGETCMAP  the palette and setup
the 8bit converter for it? As far as I can see the 8bit converter is already
there for the 8bps xlib case.

Yours,

-- 
  René Rebe - ExactCODE - Berlin (Europe / Germany)
  http://exactcode.de | http://t2-project.org | http://rene.rebe.name
  +49 (0)30 / 255 897 45