[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] evas / svg configure issue and solution



On Wed, 30 Aug 2006 21:19:40 -0500 (CDT) "D. Hageman"
<dhageman@dracken.com> wrote:

> 
> On Thu, 31 Aug 2006, Carsten Haitzler wrote:
> 
> > On Wed, 30 Aug 2006 13:27:34 -0500 (CDT) "D. Hageman"
> > <dhageman@dracken.com> babbled:
> >
> >>
> >> I mentioned before the weekend that I was having some issues with
> >> the SVG in evas with Fedora Core 5.  I finally found the time to
> >> investigate the issue some more, but I am not sure how to fix it.
> >>
> >> Essentially this solves the problem:
> >>
> >> 944c944
> >> <       PKG_CHECK_MODULES(CAIRO_SVG, cairo-svg,
> >> ---
> >>>       PKG_CHECK_MODULES(CAIRO_SVG, libsvg-cairo,
> >>
> >>
> >> Fedora Core calls their cairo-svg ... libsvg-cairo.  I am not well
> >> versed enough in autofoo to make both of those happy.
> >
> > in cvs - check that it's working for you.
> 
> Still not completely happy yet ...
> 
> In file included from evas_image_load_svg.c:4:
> /usr/include/librsvg-2/librsvg/rsvg-cairo.h:28:19: error: cairo.h: No
> such file or directory
> In file included from evas_image_load_svg.c:4:
> /usr/include/librsvg-2/librsvg/rsvg-cairo.h:33: error: expected 
> declaration specifiers or '...' before 'cairo_t'
> /usr/include/librsvg-2/librsvg/rsvg-cairo.h:36: error: expected 
> declaration specifiers or '...' before 'cairo_t'
> 
> I will try to get some time tomorrow to do more investigation if you
> don't have any ideas of the top of your head.

I have noticed that it is very librsvg version dependant.  evas should
be checking for the later version 2.13 that has the proper include
files.

Attachment: signature.asc
Description: PGP signature