[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] Entranced does not start entrance properly



On Sun, 27 Aug 2006 14:50:24 +0300
Eugen Minciu <minciue@gmail.com> wrote:
I found out what was causing the problem. Just like it says in the code.

      /* FIXME: need to parse command and NOT go thru /bin/sh!!!! */
      /* why? some /bin/sh's wont pass on this SIGUSR1 thing... */

apparenty dash is one of those /bin/sh's :(
Maybe it would be better if we were to check that "/bin/bash" exists and execute that instead of /bin/sh if it does?

If that seems OK to you guys I'll write the patch in a couple of hours.
> On Sun, 27 Aug 2006 14:39:45 +0300
> Eugen Minciu <minciue@gmail.com> wrote:
> 
> Sorry, I ran the debug again. It isn't corrupted. There was a \000 at the end of the string like there should have been, it was just gdb printing more data beyond that \000
> The command that get executed is:
> /usr/X11R6/bin/X -quiet -nolisten tcp vt7 -auth /var/lib/entrance/:0.Xauth :0
> 
> > Hi, I have an issue with running entranced.
> > 
> > I have a Debian 3.1 Testing box with XOrg 7.0.0 running. I've compiled Entrance sucessfully but running entranced (either directly, or from /etc/init.d/entrace) does not start entrance itself.
> > 
> > When I run entranced, X starts but entrance does not start within it. After this, entranced bails out, saying it cannot start the X server. However, the X server is successfully started, and it continues to run after entranced has quit.
> > 
> > Also, If i start xinit -e entrace, entrance starts successfuly.
> > 
> > I had already compiled entrance with -g and I tried debugging it, but I'm not a genius at that. It seems to me that before x is started the x_cmd variable is somehow corrupted.
> >
>  
> > Is there any chance of that happening? How do I turn debugging on so I can see more of what's happening? What other information would you guys want? 
> > 
> > Cheers,
> > Eugen.