[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] Network connection from a different thread



Any ideas?

On Thu, 3 Aug 2006 00:30:49 +0200
Andrew Sevcsik <sevcsik@citromail.hu> wrote:

> Hi list.
> 
> I tried to connect to a jabber server from a different thread, while i
> was in the ecore_evas main loop. I tried it in Ruby (XMPP4R and
> jabber4r libraries), and in C (Loudmouth library). Loudmouth has an
> implented connect function, wich is done in a different thread, and
> than calls a callback func. In ruby, I started the threads with
> Thread.new{}.
> 
> The problem is that I can't connect from a different thread. The
> thread stops at connecting (resolving the server's domain). But
> everything works fine in the other thread, until I try to connect to
> the network. Once I quit ecore main loop, the thread continues
> without errors (connection is successful).
> 
> How can I connect, while I'm in the main loop (in a different thread,
> so the GUI don't freeze)?
> 
> Thanks for the help.
> 	Sevcsik