[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] Trouble compiling E17 cvs.



On Thu, Jul 06, 2006 at 10:47:54PM -0700, Scott Prader wrote:
> Hello everyone, I'm running Debian unstable (sid) with several packages 
> held in place (like autoconf) so that things will build.  Everything 
> builds alright, except for E (apps/e) itself.  This has been going on 
> for nearly a month now and it's gotten to the point of irritation.  I 
> found another post regarding this same bug on the enlightenment-users 
> list here:
> 
> http://sourceforge.net/mailarchive/message.php?msg_id=18782556
> 
> but it doesn't look like it made it to the developers.  So here is the 
> same error message again:
> 
> e_hints.c: In function 'e_hints_allowed_action_set':
> e_hints.c:593: error: incompatible type for argument 2 of 
> 'ecore_x_netwm_allowed_action_set'
> 


I'm sorry you're irritated... 

On the 7th of June, that line was added to CVS, along with the
corresponding changes in Ecore_X. It looks like for some reason you
didn't get the ecore change.


> Yes, I have read and followed through with the full conversion over to 
> X.org 7.0 and /usr/X11R6/ is no longer on the system.  At one time, 
> duplicate ecore files were detected in /usr/local, but no longer, as 
> that solved another problem.
> 

Are you sure you don't have another ecore install in some other prefix?

try: sudo find / -name libecore\*.so

--
rephorm