[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[E-devel] Trouble compiling E17 cvs.



Hello everyone, I'm running Debian unstable (sid) with several packages held in place (like autoconf) so that things will build. Everything builds alright, except for E (apps/e) itself. This has been going on for nearly a month now and it's gotten to the point of irritation. I found another post regarding this same bug on the enlightenment-users list here:

http://sourceforge.net/mailarchive/message.php?msg_id=18782556

but it doesn't look like it made it to the developers. So here is the same error message again:

make  all-recursive
make[1]: Entering directory `/home/gnea/cvs/e17/apps/e'
Making all in src
make[2]: Entering directory `/home/gnea/cvs/e17/apps/e/src'
Making all in bin
make[3]: Entering directory `/home/gnea/cvs/e17/apps/e/src/bin'
if gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../../src/bin -I../../src/lib -DUSE_E_CONFIG_H -I/usr/X11R6/include -DLOWRES_PDA=1 -DMEDIUMRES_PDA=2 -DHIRES_PDA=3 -DSLOW_PC=4 -DMEDIUM_PC=5 -DFAST_PC=6 -DE17_PROFILE=SLOW_PC -I/usr/local/e17/include -O2 -march=athlon-xp -g -MT e_hints.o -MD -MP -MF ".deps/e_hints.Tpo" \
         -c -o e_hints.o `test -f 'e_hints.c' || echo './'`e_hints.c; \
       then mv -f ".deps/e_hints.Tpo" ".deps/e_hints.Po"; \
       else rm -f ".deps/e_hints.Tpo"; exit 1; \
       fi
e_hints.c: In function 'e_hints_allowed_action_set':
e_hints.c:593: error: incompatible type for argument 2 of 'ecore_x_netwm_allowed_action_set'
make[3]: *** [e_hints.o] Error 1
make[3]: Leaving directory `/home/gnea/cvs/e17/apps/e/src/bin'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/gnea/cvs/e17/apps/e/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/gnea/cvs/e17/apps/e'
make: *** [all] Error 2

Here are a few helpful (hopefully) things:

ltmain.sh (GNU libtool) 1.5.22 Debian 1.5.22-4 (1.1220.2.365 2005/12/18 22:14:06)
autoconf (GNU Autoconf) 2.59
automake (GNU automake) 1.7.9
gcc (GCC) 4.0.4 20060507 (prerelease) (Debian 4.0.3-3)
GNU Make 3.81

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.12-1-686 i686
Current Operating System: Linux teletrantwo 2.6.16-sid #1 Sun Apr 23 04:02:21 MST 2006 i686
Build Date: 16 March 2006
       Before reporting problems, check http://wiki.x.org
       to make sure that you have the latest version.
Module Loader present

Yes, I have read and followed through with the full conversion over to X.org 7.0 and /usr/X11R6/ is no longer on the system. At one time, duplicate ecore files were detected in /usr/local, but no longer, as that solved another problem.

-Scott