[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] Ecore does not compile.



On Mon, 22 May 2006 11:22:24 +0530
Shanker Balan <shanu@shankerbalan.net> wrote:

> Hello,
> 
> Anders Troback wrote,
> > I still can't compile Ecore on FreeBSD:-(
> > 
> > 8<----------------------------------------------------------------------
> > so ../../src/lib/ecore_job/.libs/libecore_job.so ../../src/lib/ecore_evas/.libs/libecore_evas.so /usr/devel/enlightenment/e17/libs/ecore/src/lib/ecore_x/.libs/libecore_x.so
> > -lXcursor -lXrender -lXp -lXinerama -lXrandr -lXfixes -lXdamage
> > -lXss -lX11
> > -lXext /usr/devel/enlightenment/e17/libs/ecore/src/lib/ecore_txt/.libs/libecore_txt.so /usr/devel/enlightenment/e17/libs/ecore/src/lib/ecore_job/.libs/libecore_job.so /usr/devel/enlightenment/current/lib/libevas.so /usr/devel/enlightenment/current/lib/libeet.so /usr/local/lib/libjpeg.so /usr/X11R6/lib/libfontconfig.so /usr/local/lib/libfreetype.so /usr/local/lib/libexpat.so ../../src/lib/ecore_con/.libs/libecore_con.so ../../src/lib/ecore_ipc/.libs/libecore_ipc.so /usr/devel/enlightenment/e17/libs/ecore/src/lib/ecore_con/.libs/libecore_con.so /usr/devel/enlightenment/e17/libs/ecore/src/lib/ecore/.libs/libecore.so
> > -lcurl /usr/local/lib/libidn.so /usr/local/lib/libiconv.so -lssl
> > -lcrypto -lz -lm -Wl,--rpath
> > -Wl,/usr/devel/enlightenment/current/lib -Wl,--rpath
> > -Wl,/usr/local/lib -Wl,--rpath -Wl,/usr/X11R6/lib gcc: yes: No such
> > file or directory gmake[3]: *** [ecore_test] Error 1 gmake[3]:
> > Leaving directory `/usr/devel/enlightenment/e17/libs/ecore/src/bin'
> > gmake[2]: *** [all-recursive] Error 1 gmake[2]: Leaving directory
> > `/usr/devel/enlightenment/e17/libs/ecore/src' gmake[1]: ***
> > [all-recursive] Error 1 gmake[1]: Leaving directory
> > `/usr/devel/enlightenment/e17/libs/ecore' gmake: *** [all] Error 2
> > 8<----------------------------------------------------------------------
> > 
> > Any ideas out there?
> 
> I am using configgen-1.15 to generate the autofoo stuff. All of e17
> compiles just fine (TM) here.
> 
> [buffy] ~/cvs/enlightenment/e17/apps/e> pkg_info -x configgen
> Information for configgen-1.15:
> 
> Comment:
> Script that makes life a little easier with gnu-autotools
> 
> However, apps/e broke recently with a evas_font_available_list_free
> problem. Not quiet sure why but I have rebuilt everything dependant.
> 
> e_font.o(.text+0x2d7): In function `e_font_available_list': :
> undefined reference to `evas_font_available_list'
> e_font.o(.text+0x34d): In function `e_font_available_list': :
> undefined reference to `evas_font_available_list_free' gmake[3]: ***
> [enlightenment] Error 1 gmake[3]: Leaving directory
> `/home/shanker/cvs/enlightenment/e17/apps/e/src/bin'
> 

I found it, I had an old option in my build script, --with-iconv-link
was needed before...not any more:-)

Thanks for your time!!!


\\troback

-- 

============================================
Microsoft is not the answer.
Microsoft is the question.
And 'No' is the answer!
--------------------------------------------
Anders Trobäck
http://www.troback.com