[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] FC5 & anon CVS build of Eterm



On 3/29/06, Nathan Ingersoll <ningerso@gmail.com> wrote:
> On 3/28/06, Laurence Vanek <lvanek@charter.net> wrote:
> >
> > I followed Nathan's advice and exported the flag from my .bash_profile
> > file and I was able to build Eterm again in FC5 (as I had with FC4).
> > Forgot I had done that in the past (getting old).  Still dont understand
> > this but hey it works.
>
> Libast installs a libast.m4 file for some extra macros to extend
> autotools. Eterm uses the macros in that file in it's configure.in. By
> default autotools is installed in /usr, so it uses /usr/share/aclocal
> to hold it's m4 files. Since libast is getting installed in
> /usr/local, it installs its m4 file relative to that path too, so
> /usr/local/share/aclocal, but this isn't a location /usr/bin/aclocal
> looks in by default. The export ACLOCAL_FLAGS="-I
> /usr/local/share/aclocal" tells aclocal to also look in that directory
> for m4 files it needs to include in it's macro definitions.
>

Yes I had understood that but using RPM spec file macro %configure
forces libast to get installed in /usr. So for me the  ACLOCAL_FLAGS
were not the problem. An update in CVS fixed everything. But thanks
for the explanation. And that helped Laurence!


--
With kind regards,
Didier.

------------
Yum/apt repository for DR17/EFL: http://sps.nus.edu.sg/~didierbe

Didier F.B Casse
PhD candidate, Singapore Synchrotron Light Source (SSLS)
National University of Singapore.