[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [E-devel] esmart looking for ltdl.h on Fedora Core 5



OK FORGET THIS EMAIL.

Strangely it appears after trying with yum a few times. :(
Seemed to have been a problem with yum which failed to download or see
the required libtool-ltdl-devel a while ago. Pff..

On 3/24/06, Didier Casse <didier.casse@gmail.com> wrote:
> On 3/24/06, The Rasterman Carsten Haitzler <raster@rasterman.com> wrote:
> > On Fri, 24 Mar 2006 04:40:59 +0800 "Didier Casse" <didier.casse@gmail.com>
> *snip*
> _________________________________________________________-
> > >
> > > Any suggestions on how to bypass the
> > > /usr/bin/ld: cannot find -lltdl would be appreciated. Thanks.
> >
> > libltdl is a system library. its a wrapper around dlopen and whatever other forms of dynamic loading are possible on a system if that isn't there. it was split FROM libtool as it is used runtime. it seems fedora have decided to basically neuter the package and software. i guess that means esmart is now not compatible with fedora - unless u missed there being another package that now ships libltdl.so* and ltdl.h
>
>
>
> Well that was my point. I'm still looking for the DEVEL package which
> I can't find in the usual ways.
>
> To Vapier: Yes it would be nice not to hack and to find the damn DEVEL
> package. I could be wrong but from first looks, it seems that they
> merged the whole thing. Have a look below:
>
> [root@localhost ~]# yum whatprovides ltdl.h
>
> libtool.i386                             1.5.22-2.2             installed
> Matched from:
> /usr/share/libtool/libltdl/ltdl.h
>
>
> [root@localhost ~]# yum whatprovides libltdl
>
> libtool-ltdl.i386                        1.5.22-2.2             core
> Matched from:
> /usr/lib/libltdl.so.3
> /usr/lib/libltdl.so.3.1.4
> libltdl.so.3
>
>
> libtool-ltdl.i386                        1.5.22-2.2             installed
> Matched from:
> /usr/lib/libltdl.so.3
> /usr/lib/libltdl.so.3.1.4
> libltdl.so.3
>
>
> libtool.i386                             1.5.22-2.2             installed
> Matched from:
> /usr/share/libtool/libltdl
> /usr/share/libtool/libltdl/COPYING.LIB
> /usr/share/libtool/libltdl/Makefile.am
> /usr/share/libtool/libltdl/Makefile.in
> /usr/share/libtool/libltdl/README
> /usr/share/libtool/libltdl/acinclude.m4
> /usr/share/libtool/libltdl/aclocal.m4
> /usr/share/libtool/libltdl/config-h.in
> /usr/share/libtool/libltdl/config.guess
> /usr/share/libtool/libltdl/config.sub
> /usr/share/libtool/libltdl/configure
> /usr/share/libtool/libltdl/configure.ac
> /usr/share/libtool/libltdl/install-sh
> /usr/share/libtool/libltdl/ltdl.c
> /usr/share/libtool/libltdl/ltdl.h
> /usr/share/libtool/libltdl/ltmain.sh
> /usr/share/libtool/libltdl/missing
> /usr/share/libtool/libltdl/
>
> I emailed the fedora list to confirm this. Thanks for the replies.
>
> ---
> With kind regards,
> Didier.
>
> ------------
> Yum/apt repository for DR17/EFL: http://sps.nus.edu.sg/~didierbe
>
> Didier F.B Casse
> PhD candidate, Singapore Synchrotron Light Source (SSLS)
> National University of Singapore.
>


--
With kind regards,
Didier.

------------
Yum/apt repository for DR17/EFL: http://sps.nus.edu.sg/~didierbe

Didier F.B Casse
PhD candidate, Singapore Synchrotron Light Source (SSLS)
National University of Singapore.